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Profile Help is showing a blank window on the workstation

by Intuit Updated 6 days ago

Issue

Some customers may have a problem where the ProFile Help feature works well on the server but doesn't work well on a workstation. When accessed from the workstation, the page displays blank. It might look like this:

Left pane (Contents/Index) works and loads correctly.

Right pane (HTML content) is completely blank.

Cause

This behaviour is caused by a built-in Windows Security Feature (present since Windows XP)

Workaround

To resolve this issue, you will need to add the server to the workstation's Trusted Intranet Zone and update the HTML Help restrictions in the Windows Registry using PowerShell.

Perform the following steps on the impacted workstation:

Table of contents:

Add the Server to the Trusted Intranet Zone

  1. Open the Windows Start menu and search for Internet Options (or access it via the Control Panel).
  2. Go to the Security tab.
  3. Select Local Intranet, select Sites, and then select Advanced.
  4. In the "Add this website to the zone" field, enter the following:

File URL Displaying Server IP Address Placeholder

Important: Replace the above with your server's actual IP address

  1. Ensure the box for Require server verification (https:) for all sites in this zone is unchecked.
  2. Select Add and Close, and then OK to save your settings.

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A black and white photo of a street light.

Run PowerShell Commands as Administrator

  1. Right-click the Windows Start menu and select Windows PowerShell (Admin) or search for PowerShell and select Run as Administrator.
  2. Copy and paste the following commands into the PowerShell window.
# Run PowerShell as Administrator

New-Item -Path "HKLM:\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions" -Force Set-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions" -Name "MaxAllowedZone" -Value 2 -Type DWord

New-Item -Path "HKLM:\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x\ItssRestrictions" -Force Set-ItemProperty -Path "HKLM:\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x\ItssRestrictions" -Name "MaxAllowedZone" -Value 2 -Type DWord
  1. Select Enter.

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Restart ProFile Workstation

Close out of all windows and restart the ProFile Workstation.

The Help feature should now successfully load the HTML content in the right pane.

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